icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.jinxingfrp.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

北京28 www.859889.com-瑞彩祥下载链接| www.026234.com-一分钟黑彩号码破解| www.161151.com-玩彩网最新app| www.269179.com-海拔彩票下载| www.193978.com-快三豹子最佳规律| www.32jo.com-体彩星期五什么开奖| www.972386.com-体彩排列三开奖查询| www.212574.com-私彩老平台-| www.317002.com-七乐彩玩法技巧| www.399155.com-体育彩票开票几点| www.88795.cc-彩聊-| www.417744.com-彩虹6号ela图片| www.559805.com-内蒙时时彩今日开奖| www.412041.com-鸿运当投彩票| www.530526.com-重庆时时彩预测技巧| www.935107.com-ios玩彩票的软件| www.2200.tv-红彩绘app下载| www.388235.com-太平哨华彩学校全景| www.513756.com-超级快5是什么彩票| www.617408.com-彩票开机号下载| www.702071.com-竞彩优化软件app| www.42dd.com-七彩球中国福利彩票| www.1899.xyz-时时彩区间打法技巧| www.9938.live-彩票开奖查询一一| www.127224.com-彩铅画教程星空| www.224539.com-兼职帮投福彩游戏| www.9798.biz-七星彩中奖在哪里领| www.bw35.com-4scc彩票乐库| www.633666.com-神彩通3d-| www.787224.com-极速快三博彩走势图| www.867721.com-快三规律表-| www.971823.com-博彩庄家对冲| www.i04.net-体彩七位数几点开| www.44517.com-彩票今日中彩| www.547682.com-体彩e彩-| www.686221.com-彩色混凝土着色地坪| www.838668.com-易彩输了钱怎么办| www.091793.com-大联盟彩票-| www.443725.com-掌上彩五肖十码网站| www.654075.com-江西快三玩法技巧| www.zu85.com-翼龙无人机和彩虹5| www.0822.xyz-欧冠体育彩票| www.702987.com-体彩刮刮乐手机兑奖| www.106512.com-福彩双色球中彩| www.283531.com-够力七星彩规律表| www.bb94.com-最专业彩票选号软件| www.07pn.com-彩票码的资料| www.5557.pw-下载d8彩票-| www.59998.cc-卓易彩票电脑版| www.3306.cn-体彩机选排列五号码| www.020775.com-北京快三和值遗漏| www.336538.com-河北体彩一定牛| www.005127.com-彩民论坛推荐号| www.282654.com-彩票规律的计算软件| www.509930.com-河内五分彩在线计划| www.172818.com-全天大发快三计划| www.592265.com-彩虹无人机和大疆比| www.226.red-彩民最新故事| www.12827.cc-史蒂芬彩票算法公式| www.062495.com-553彩票app-| www.736417.com-保定市福彩中心电话| www.2604.shop-福彩复式结果| www.353288.com-彩铅笔手绘大师作品| www.337759.com-可以购买彩票的软件| www.916939.com-油性彩铅画教程| www.979869.com-体彩自助终端机投标| www.ag47.cc-双色球走势图彩宝贝| www.055686.com-六位数的彩票网赌| www.392106.com-在线彩票平台哪个好| www.581714.com-芒果彩票平台| www.701701.cc-3d红人玩彩| www.839723.com-500足彩完场比分| www.964269.com-大乐透彩票筛选软件| www.886312.com-彩铅画图片大全简单| www.xr5.cc-吉林快三开奖结果查| www.895.cm-下载福彩3d字谜| www.89572.com-下载577彩票| www.212300.com-大发优彩网-| www.23171.com-彩神app争霸| www.09993.cc-快乐彩票五平台| www.012757.com-南国七星彩开奖号码| www.337498.com-免费体验彩金| www.224245.com-网上快三害人吗| www.j03.com-彩票精准计划听过| www.794305.com-微信腾讯彩票游戏| www.946686.com-福彩3d组六走势| www.bp44.com-易彩官方网下载| www.32.me-竞彩足球规则及玩法| www.820456.com-道教灵符彩票中奖符| www.235664.com-齐鲁彩票中奖号码| www.376018.com-网络购彩何时恢复| www.629121.com-47彩票下载-| www.773303.com-晶彩靓妍美白祛斑霜| www.733178.com-245彩票下载| www.137112.com-国家福利彩票网站| www.283926.com-什么彩票是2位数| www.474256.com-体彩乐呱呱在线试刮| www.992433.com-竞猜资讯竞彩网| www.za82.com-福彩传统彩十选五| www.33228.cc-四川体彩金七宝| www.6802.vip-香港彩宝典ios| www.32275.com-竞彩小章鱼-| www.dy39.com-吉林快三盘有鬼吗| www.365722.cc-彩铅森林主题画| www.396468.com-香港中彩堂| www.304039.com-甘肃快三玩法介绍| www.869948.com-彩票计划员是拖么| www.087068.com-乐福彩票平台怎样| www.311391.com-三分彩网站-| www.436852.com-福彩3d研究院| www.627046.com-二十选五福彩| www.752216.com-悟空彩票-| www.862667.com-体彩大乐透开奖| www.971465.com-88彩票是正规网站| www.xk.com-中彩彩票中福快3| www.g79.net-6合和彩资料| www.613169.com-中港彩票抢红包活动| www.813740.com-辽宁省体彩11选5| www.98956.com-qq时时彩-| www.079626.com-3d彩票规则玩法| www.151971.com-竞彩看盘教程| www.251676.com-01彩票平台合法吗| www.996086.com-杨震足彩最新一期| www.008571.com-胜负彩19039期| www.79jq.com-国彩快三是什么| www.33131.com-福彩快频彩是什么| www.055677.com-容易中奖的彩票数字| 体彩网www.3890s.com| www.528175.com-彩票之家是什么| www.654794.com-七星彩2023图规| www.810983.com-竞彩单场比分奖金| www.oi6.com-甘肃快三出号统计| www.256277.com-福彩快3网上购买| www.390801.com-8号彩票软件下载| www.zs46.com-福彩彩票注销流程| www.61ox.com-福彩3d走和值号码| www.025420.com-体彩新型终端机| www.116738.com-几点买彩票中奖率高| www.234116.com-今天快三出奖号码| www.293959.com-福利彩票42期| www.432499.com-买彩票10年-| www.554416.com-彩票怎么看呢| www.239218.com-福彩3id今晚推荐| www.461133.com-彩票源码是什么意思| www.699564.com-竞彩pc版-| www.666861.com-95彩.com-| www.759787.com-高材生彩票审判| www.832079.com-093彩票是真的吗| www.917273.com-网站上买彩票被骗| www.966931.com-河南快三怎么买稳中| 易彩网www.12455y.com| www.595574.com-黑彩刘雪龙-| www.539888.cc-各大彩票期望值| www.825848.com-体育彩票aqq| www.900523.com-体彩排列5玩法介绍| www.961781.com-综艺福彩-| www.27fq.com-有云购彩票是真的吗| www.382992.com-体彩大乐透第16期| www.111303.com-彩民堂-| www.871394.com-中国福彩总汇图九| www.203950.com-内蒙快三一下载| www.7253.cn-彩虹挂在天上像什么| www.116801.com-福彩十选五骗人| www.7jp.com-怎么利用生日买彩票|